You entered the name correctly in your Google Admin Console or Active Directory. What's the deal with students showing as PENDING?
There are a few possible causes depending on the scenario. Let's take a look at what could be causing this and how to fix it.
Note: If the user has never signed into an applicable device with their school email, that can result in their name not being available to be pulled over to GoGuardian's database. It is always recommended to confirm that the student has signed into a device with their school email at least once as an initial troubleshooting step.
Scenario 1:
The student is using a connected Chromebook (either a school-issued/school-managed device or the student has been confirmed to be signed into a personal Chromebook under their school email). Browsing data is showing for the student in GoGuardian Admin, but the name still shows as Pending.
Cause 1:
There's a delay in the name being grabbed from the browser. When the student signs in for the first time after your GoGuardian extensions have been deployed, there can be a short delay of a few minutes for the student's name to be pulled from: https://accounts.google.com/AccountChooser/signinchooser?flowName=GlifWebSignIn&flowEntry=AccountChooser
The name of the user is pulled when the extension automatically scrapes the user's name field from this page.
Troubleshooting steps:
- Allow between 30 and 60 minutes of use to see if the name updates in GoGuardian. Then, try refreshing the page to see if any changes have come in.
- If they have not come in after 60 minutes have passed, it could be due to the name length (see Cause 2) or some other issue that prevented the student's name from being pulled properly.
Solution 1:
Reach out to tech support and provide the name and email of the student to have corrections made (If there are multiple students showing this way, please create a CSV file to share with us that includes the student names and their corresponding emails so that can be corrected).
Scenario 2:
The student's name is more than 20 characters long.
Cause 2:
Names that are 20 characters or more cannot be automatically pulled and must be submitted through tech support to have the student's name manually added in
Solution 2: (same as Solution 1)
Reach out to tech support and provide the name and email of the student to have corrections made (If there are multiple students showing this way, please create a CSV file to share with us that includes the student names and their corresponding emails so that can be corrected).
Scenario 3: (Windows)
You have implemented the Windows setup for GoGuardian using our Windows install guide. The student is signed into their Windows device, but they are showing as Pending in GoGuardian Admin.
Cause 3:
The student either isn't signed into the Chrome browser.
Solution 3:
Ensure that the student is signed into the Chrome browser using their school email. (Note: The student must be signed into their chrome profile versus being signed into their Gmail/G suite account only. Here's a video that goes over the difference:
Click here to watch the video!
If the student isn't signed into their chrome profile, their GoGuardian extensions won't properly be pushed to their computer/account).
Cause 4: (same Windows scenario)
The application/registry key isn't properly connected.
Solution 4:
You can use the Windows troubleshooting guide to make sure that no important steps were missed or in need of correction when going through the setup for Windows. You can find the Windows troubleshooting guide here.
Comments
0 comments
Please sign in to leave a comment.